[ECOS] PC target -- How to build the GDB stub Floppy ?

Rene.Affourtit@pemstar.nl Rene.Affourtit@pemstar.nl
Sun Apr 2 23:44:00 GMT 2000


It's a Cygwin problem, I had a similar experience using an Arn board. Here
is the response I got from the cygwin list:

     From: Chris Faylor <cgf at cygnus dot com>
     Subject: Re: B20: serial ports status?
   On Thu, Mar 23, 2000 at 11:00:26AM +0100, Rene.Affourtit@pemstar.nl
   wrote:
   >In november 1998 there was a question regarding "gdb serial
   >cross-debugging" (
   > http://sourceware.cygnus.com/ml/cygwin/1998-11/msg00297.html )
   >
   >1:  Has anyone succesfully talked to the arm-Angel using a serial line
   and
   >using b20? If so what version of gdb /angel did you use?

   Serial I/O in b20 is broken.

   >2: Have these problems been solved  in any of the snapshots? if so
   which
   >one?

   There is apparently a problem with an interaction between the arm-Angel
   and cygwin.  It is strange in that no other targets are reported to be
   affected.  This is true of recent snapshots, also.

   Sorry.  I would like to have someone debug and fix this problem but the
   current state is that there is no fix.  Well... actually someone here
   did create a DLL that seemed to work around the problem but I don't
   think
   that it actually solved anything.  They just compiled the cygwin
   select.cc
   file with -g rather than with "-O2 -g".

   Christopher Faylor
   Cygwin Engineering Manager
   Cygnus Solutions, a Red Hat company



                                                                                                                                    
                    Nick Garnett                                                                                                    
                    <nickg@cygnus.co.uk>                  To:     "Rosimildo daSilva" <rosimildo@hotmail.com>                       
                    Sent by:                              cc:     ecos-discuss@sourceware.cygnus.com                                
                    ecos-discuss-owner@sourceware.        Subject:     Re: [ECOS] PC target -- How to build the GDB stub Floppy ?   
                    cygnus.com                                                                                                      
                                                                                                                                    
                                                                                                                                    
                    03/31/00 07:17 PM                                                                                               
                                                                                                                                    
                                                                                                                                    




"Rosimildo daSilva" <rosimildo@hotmail.com> writes:

> I've got the GDB stub built. Loaded it in an old pentium machine
> and it seems to boot. I see some numbers in the upper corner.

Great, that sounds right.

> under GygWin, I see that a couple of lines gets printed on the
> target( stub ), and the connection fails.
>
> GDB prints something like:
> putpkt error: permission denied.  ( something like that )
>

Hmm, this sounds like an NT problem. Not my area of expertise,
unfortunately.  Hopefully someone more expert will be able to help
here.


--
Nick Garnett
Cygnus Solutions, a Red Hat Company
Cambridge, UK








More information about the Ecos-discuss mailing list