[PATCH 2/4] Handle DW_FORM_data16.
Mark Wielaard
mark@klomp.org
Fri Sep 25 16:42:23 GMT 2020
Hi,
On Thu, 2020-09-24 at 21:43 +0200, Jakub Jelinek wrote:
> On Thu, Sep 24, 2020 at 06:25:55PM +0200, Mark Wielaard wrote:
> > @@ -1709,6 +1710,9 @@ skip_attr_no_dw_form_indirect (unsigned int
> > cu_version, uint32_t form,
> > case DW_FORM_ref_sig8:
> > ptr += 8;
> > break;
> > + case DW_FORM_data16:
> > + ptr += 16;
> > + break;
> > case DW_FORM_sdata:
> > case DW_FORM_ref_udata:
> > case DW_FORM_udata:
> > @@ -2975,6 +2979,9 @@ checksum_die (DSO *dso, dw_cu_ref cu,
> > dw_die_ref top_die, dw_die_ref die)
> > die->die_no_multifile = 1;
> > ptr += 8;
> > break;
> > + case DW_FORM_data16:
> > + ptr += 16;
> > + break;
>
> Also, wonder if DW_FORM_ref_sig8 has a separate case from DW_FORM_data8, if
> it wouldn't be more readable to stick DW_FORM_data16 case below the
> DW_FORM_data8 one. When both are the same case, that isn't possible of course.
In the case of skip_attr_no_dw_form_indirect DW_FORM_ref8,
DW_FORM_data8 and DW_FORM_ref_sig8 are the same case (and
DW_FORM_data16 immediately follows that case), but in the case of
checksym_die they are different cases. I moved DW_FORM_data16 right
after DW_FORM_data8 in that case.
> Otherwise LGTM.
Thanks,
Mark
More information about the Dwz
mailing list