Ctrl+Space not working under Windows Terminal

Ken Brown kbrown@cornell.edu
Sun Sep 4 15:48:05 GMT 2022

On 9/2/2022 9:33 PM, Ricardo Urbina wrote:
> Hi, I'm trying out Cygwin's Zsh within Windows Terminal because WT
> integrates better with WSL, but Cygwin beats it for working on the Windows
> side.
> However, I launched emacs and eventually noticed that Ctrl+Space doesn't
> work when running under Windows Terminal.

It works on my system.  Here's what I did:

1. Start Windows Terminal and run

   /path/to/cygwin/bin/zsh -l

2. Launch emacs:

   emacs-basic -Q

3. Within emacs, type

   C-h k C-SPC

I then see "C-@" echoed in the minibuffer, and the resulting *Help* buffer says

   C-@ runs the command set-mark-command (found in global-map), which
   is an interactive compiled Lisp function in ‘simple.el’.

   It is bound to C-@, C-SPC.

And typing C-SPC does indeed set the mark.

I'm not sure what's different on your system.  Could there some be some setting 
that's causing C-SPC to be eaten by Windows Terminal instead of being sent to 
emacs as C-@?

By the way, if I run emacs-w32 instead of emacs-basic, everything is the same 
except that in the first line of the *Help* buffer "C-@" is replaced by "C-SPC". 
  So emacs-w32 is actually seeing the C-SPC keypress.

Have you tried emacs-w32 to see if that works better for you?


More information about the Cygwin mailing list