Switch to a new PC

Vanda Vodkamilkevich vanda.vodkamilkevich@gmail.com
Thu Feb 10 14:41:20 GMT 2022


I've retried with the 'P' option and now I get it: when using this option
the package selection page doesn't show it as 'selected' (no version or
action seen in the 'New' column') but if you click 'next' it works!  I
don't know how to send a screenshot but I hope that you get what I mean.

When I made my first attempt I was confused with this display and I just
stopped instead of continuing... Maybe the graphical interface should
reflect somehow the '-P' chosen packages?

Le jeu. 10 févr. 2022 à 14:54, Jon Turney <jon.turney@dronecode.org.uk> a
écrit :

> On 09/02/2022 18:05, Adam Dinwoodie wrote:
> > On Wed, Feb 09, 2022 at 04:12:28PM +0100, Vanda Vodkamilkevich wrote:
> >> On Fri, Feb 4, 2022 at 13:12  AM  marco.atzeri  wrote:
> >>
> >>>> I wouldn't expect most tools to work on special files in /dev. Even
> tar
> >>>> fails on /proc, it would begin to pack your local registry...
> >>>> Make a basic installation on the new system, then sync the rest.
> >>>> An even cleaner way might be to clone your installation via setup,
> using
> >>>> /etc/setup/installed.db - maybe someone has a script for that -
> >>>> and then just sync the /home hierarchy.
> >>>
> >>> script I wrote some time ago for re-installation
> >>>
> >>>
> >>
> https://stackoverflow.com/questions/46829532/cygwin-save-package-selections-for-later-reinstall/
> >>>
> >>>
> >> Just for the record:
> >> I just played with the script provided in stackoverflow which generates
> a
> >> bat file, and it seems that the behaviour of the '-P' switch of setup
> has
> >> changed because now it explicitely needs the version of the package (at
> >> least for me it didn't worked without the version number:  " -P
> >> package=version_as_seen_by_cygcheck") . Can someone (probably Jon
> Turney)
> >> confirm this usage of the '-P' switch (BTW the mandatory '='  is
> explained
> >> nowhere - Nor in 'setup -h' or the setup web pages - and can be seen
> only
> >> in  the source code).
>
> It's not mandatory.  If you're looking at the source code, you should
> see that the case where '=' is not present is also still handled.
>
> Yes, it should be documented, but so should the rest of the format of
> the string which -P accepts...
>
> > I don't think this is correct.  I use the setup program's -P option
> > regularly, including with the latest 2.917 release, and it successfully
> > installs packages.  Indeed, I've just tried running it to install
> > 2048-cli (given it's a package I know I don't have installed) and it
> > successfully installed the package without specifying a version number.
> >
> > Can you give a bit more information about exactly what commands you're
> > running, what you're expecting to happen, and what precisely happens
> > instead?
>
> Yeah, what he said :)
>
> That's not to say that -P isn't picky in the precise format of the
> package list it accepts (that might have unfortunately changed), and the
> error reporting when the package list doesn't meet it's expectations is
> weak, but it works for me, so an instance of a setup invocation which
> fails because it doesn't contain '=' would be very helpful.
>
>


More information about the Cygwin mailing list