single key stroke `git add -p` bug

Adam Dinwoodie
Thu Aug 25 10:34:45 GMT 2022

On Thu, Aug 25, 2022 at 01:17:28AM +0200, trashyankes wrote:
> Hello   I update recently all cygwin packages and after that `git add
> -p` stop working correctly.  (previous update I did around 2 month
> ago)  I use mintty on Windows 10 x64, and have set `git config
> --global interactive.singlekey true` when I run this command whole
> terminal freeze and show message from git:  ```  warning: reading
> single keystrokes not supported on this platform; reading line instead
> ```  mintty stop accepting any input even `Ctrl-C`.   I tried to
> revert mintty and git to older version but every one available have
> same behavior.  For now disabling `singlekey` make this git operation
> work again but this is big lose in productivity.

Confirmed.  I'm not sure what's going wrong here: as I understand it,
this function depends on the Term::ReadKey Perl module, provided by the
Cygwin perl-TermReadKey package, but that package is correctly listed as
both a buildtime and runtime dependency for the git package.

I'll add to my queue to do some more debugging, but I'm not expecting to
have time to do any serious investigation here for a while.  Obviously
if anyone else is able to identify the problem, I'm very happy to
consider patches!

(Cygwin Git maintainer)

More information about the Cygwin mailing list