[Attn: mercurial maintainer] hg fails with python3.9

Jari Aalto jari.aalto@cante.net
Fri Apr 29 09:46:03 GMT 2022


On 2022-04-28 10:27, Ken Brown wrote:
> /usr/bin/hg specifies /usr/bin/python3 in its shebang, but further down it has
> 
>   libdir = '../lib/python3.8/site-packages'
> 
> This causes hg to fail as follows if /usr/bin/python3 points to python3.9:
> 
> $ hg
> Traceback (most recent call last):
>   File "/usr/lib/python3.8/site-packages/mercurial/policy.py", line 69, in

While uploading fix, I got this:

  ERROR: package 'mercurial' version '5.7-3' is most recent non-test version, but version '6.0-1' is curr:

Jari


More information about the Cygwin mailing list