Previously-functional gawk script now failing to execute - PLEASE HELP!!!

Brian Inglis Brian.Inglis@SystematicSw.ab.ca
Thu Sep 16 01:58:47 GMT 2021


On 2021-09-15 15:11, Bryan VanSchouwen via Cygwin wrote:
> I just tried executing an old, previously-functional awk script using a
> version of gawk that I had downloaded last year, and a command of the
> following format (as recommended in a previous communication with the
> Cygwin mailing list):
> gawk -vRS="\r\n" -f data_collect_e_-_FF_4-state.awk
> but this time, the script failed to execute!!
> 
> Upon closer examination, the script appears to be failing after
> successfully reading the first line of data from the input data file, even
> though the input file has NOT been modified since it was last used.  (I
> should point out that while the files were copied over from my old
> computer, another awk script execution that I had attempted recently with
> older files worked fine!)

So the script is not failing to execute, it is successfully reading the 
first line: so how is it failing, and what has that to do with the input 
file being modified, and if the input file has not been modified since 
the script was last used, why are you rerunning it?

Package gawk has been updated once a year for the last 4 years, up until 
2020-04, and has not changed recently, so the problem may be with your 
data file, or the script, or your Cygwin installation, and only you can 
really answer that, as they have been "copied" from another computer: 
using what process? How was Cygwin setup on the new computer, and which 
version of gawk was installed to be used?

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in binary units and prefixes, physical quantities in SI.]


More information about the Cygwin mailing list