cygrunsrv + sshd + rsync = 20 times too slow -- throttled?

Chris Roehrig
Fri Sep 3 20:59:25 GMT 2021

On Fri Sep 3 2021, at 12:55 PM, Corinna Vinschen <> wrote:

> [resent, this time with the ML in To]
> On Sep  2 12:03, Chris Roehrig wrote:
>> On Thu Sep 2 2021, at 8:25 AM, Ken Brown via Cygwin <> wrote:
>>> On 9/1/2021 5:11 PM, Chris Roehrig wrote:
>>>> I rebuild procps from source and it appears to work, so maybe the stock procps package is incompatible with the current master branch.
>>> Maybe, but it could also be a Cygwin bug.  I'll do a bisection of the Cygwin sources to see if I can track it down.
>> I did some more tests and it still doesn't completely work:
>> 	procps -ef		# works
>> 	procps -eo user,stime,tty,time,args	# works
>> 	procps -eo pid  # fails with that same mmap() error
>> I also rebuilt it all using cygport and it gives the same error (pscommand.exe with no args).
> Since you're building Cygwin by yourself anyway, can you do me a favor
> and try this:
> $ git revert 2f05de4dbf9c
> and see if that fixes your issue?

I got procps working I think (both with and without the revert).

I think the problem might just be that I wasn't also copying the rebuilt /bin/cygprocps-8.dll to match the /bin/procps.exe.    There's some tricky renaming that make install does, so I did 'make install DESTDIR=/tmp/install' and copied just those two files.     I'm guessing it would all work on a properly fully installed build.

-- Chris

More information about the Cygwin mailing list