cygrunsrv + sshd + rsync = 20 times too slow -- throttled?

Corinna Vinschen corinna-cygwin@cygwin.com
Fri Sep 3 19:55:47 GMT 2021


[resent, this time with the ML in To]

On Sep  2 12:03, Chris Roehrig wrote:
> 
> On Thu Sep 2 2021, at 8:25 AM, Ken Brown via Cygwin <cygwin@cygwin.com> wrote:
> > On 9/1/2021 5:11 PM, Chris Roehrig wrote:
> >> I rebuild procps 3.3.17.29-2480 from source and it appears to work, so maybe the stock procps package is incompatible with the current master branch.
> > 
> > Maybe, but it could also be a Cygwin bug.  I'll do a bisection of the Cygwin sources to see if I can track it down.
> 
> I did some more tests and it still doesn't completely work:
> 	procps -ef		# works
> 	procps -eo user,stime,tty,time,args	# works
> 	procps -eo pid  # fails with that same mmap() error
> 
> I also rebuilt it all using cygport and it gives the same error (pscommand.exe with no args).

Since you're building Cygwin by yourself anyway, can you do me a favor
and try this:

$ git revert 2f05de4dbf9c

and see if that fixes your issue?


Thanks,
Corinna


More information about the Cygwin mailing list