cygport build injecting /usr/lib/gcc/x86_64-pc-cygwin/7.4.0/ paths

Brian Inglis
Sun Nov 14 13:49:27 GMT 2021

On 2021-11-14 05:48, Achim Gratz wrote:
> Brian Inglis writes:
>> Got these errors trying to build latest ncurses on my system, so
>> retried on scallywag and got same result, with no clue where that is
>> coming from!

> Unless there is absolutely no other way and you know exactly what you're
> doing, never skip the cygautoreconf in src_compile.

I always try to use the default src_compile autotools.cygclass function 
where possible to ensure that is the case.
Various GNU tool builds have that commented out by their previous 
experienced maintainers, so I tread carefully.
I do try to re-add the cygautoreconf function and comment out the 
src_compile function override where possible even in those cases.
I leave the commented out version in place to document the possibility 
that re-trying a build without cygautoreconf may fix issues.

In this case, all such alternatives (cygautoreconf, libtoolize, lndirs) 
tried either had no effect or broke the builds, which as I said, seem to 
have all the autoconf and automake files pre-generated, so that cygconf 
and cygmake should work, given a functional libtool.

I have also tried to rebuild libtool from sources to pick up updates, 
but that cygport build no longer even generates a Makefile!
However I notice that the tar contains a slew of .file temporaries that 
may be messing up that build.

Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in binary units and prefixes, physical quantities in SI.]

More information about the Cygwin mailing list