AW: Setup: gio-querymodules.exe - Entrypoint not found

Klaas Dieckhoff
Fri Jun 18 07:08:32 GMT 2021

First of all sorry for sending this from another address, but my other one
seems to be blocked by the spam filter...

> > While installing Cygwin on my Windows 10 machine I got the attached

> > error message twice. Unfortunately it’s in german, but it translates to:

> > procedure entrypoint "_idn2_punycode_decode" not found in DLL

> > <path>/libgnutls-30.dll In my installation I’m for example not able

> > to use git with ssl (i.e.

> > commands like ‘git push origin master’). I already tried to

> > reinstall libgnutls-30.dll which didn’t help.

> > Any idea how to resolve this issue?


> Your subject mentions setup and gio-querymodules; your body mentions
idn2_punycode_decode, libgnutls30; plus git and git-push.


> Please copy and paste the actual commands executed and error messages
reported, including complete commands for each of the issues involved.

> There are German speakers on the list who can clarify for those of us who
may have issues decoding German tech language.

I attached a screenshot of the error message.


> I would not expect punycode to be anything to do with libgnutls.


> I would expect idn2_punycode_decode in cyg/libidn2, but it is not a
public API symbol for either Cygwin or Windows mingw libraries.


> The idn2_punycode_decode issue was a libgnutls/libidn2 compatibility
problem a couple of years ago but should be fixed now:




> Cygwin wget and wget2 are built with libgnutls and libidn2 and have no
build, test, or usage issues reported.

Okay, trying to download  a file with wget gives me a 'Scheme Missing'.


> Have you perhaps an old release of Cygwin installed and have not applied
any recent upgrades?

No, I downloaded and installed Cygwin last week, I did also check for
updates this morning. Actually there were some git related upates but this
didn't fix it.


> Do you perhaps have Git for Windows or some WSL distro installed and in
your path? Try:


>             $ which git; ls /usr/libexec/git-core/git-push

>             /usr/bin/git

>             /usr/libexec/git-core/git-push


I get the same output here then you did. Yes I had Git for windows
installed. But I removed this when trying to fix this on my own. It's maybe
worth mentioning, that git for windows also stopped being able to push
after I installed Cygwin. Before this worked and git is also still working
on my Linux VM. So I don't expect it to be some network problem.

Any other idea?



> --

> Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada


> This email may be disturbing to some readers as it contains too much
technical detail. Reader discretion is advised.

> [Data in binary units and prefixes, physical quantities in SI.]


> --

> Problem reports:

> FAQ:        

> Documentation:

> Unsubscribe info:

-------------- next part --------------
A non-text attachment was scrubbed...
Name: error_cygwin_setup.png
Type: image/png
Size: 9358 bytes
Desc: not available
URL: <>

More information about the Cygwin mailing list