how to "re-enable" perl after 5.32 install; how to reinstall all perl-mods?

ASSI Stromeko@nexgo.de
Wed Jun 2 05:47:48 GMT 2021


L A Walsh writes:
> updated cygwin and it reinstalled a new version of perl,
> but when I try to run any perl progs nothing runs (see below).
>
> So I'd like to try to reinstall all the cygwin
> perl-mods that I have installed.

You didn't say how you updated Cygwin, but if you used setup then it
already did exactly that.

> How can I select "all" among the perl mods? and install?
>
> I can select for only the "installed" perl mods, but how can
> I tell it to reinstall all of them?

I'm not sure I understand your question, but how would you re-install a
not installed module?

> According to /etc/setup, there are about 202 modules that need
> to be reinstalled, but I don't see howto tell setup to re-install
> all the "installed" modules (so I can be sure they are all "refreshed".

Again, they already should be.

> Thanks
>
> (errors from 2 of my local perl progs, "pcalc" and "dedup")
> and trying cpan....which also doesn't work. :-(
>
>
>
>>  pcalc
> Segmentation fault (core dumped)

Well, I'm afraid I can't help you with an error so non-specific.

> ##### Trying perldb:
>>  perl -d pcalc
>
> Loading DB routines from perl5db.pl version 1.57
> Editor support available.
> Enter h or 'h h' for help, or 'man perldebug' for more help.
>
> Signal SEGV at
> /usr/local/lib/perl5/site_perl/5.32/x86_64-cygwin-threads/Term/Size.pm 
> line 14.

None of the stuff in /usr/local/ comes from Cygwin, that was all put
there by yourself.  How about you move that away first?

>  require Term/Size.pm called at pcalc line 26
>  main::BEGIN() called at
>  /usr/local/lib/perl5/site_perl/5.32/x86_64-cygwin-threads/Term/Size.pm 
> line 0
>   eval {...} called at
>   /usr/local/lib/perl5/site_perl/5.32/x86_64-cygwin-threads/Term/Size.pm 
> line 0
>
> #### Another prog:
>>  dedup
> Can't locate Carp/Always.pm in @INC (you may need to install the
> Carp::Always module)...
>
> #### Try cpan:
>>  cpan
> Can't locate ExtUtils/MakeMaker/version/vpp.pm in @INC (you may need
> to install the ExtUtils::MakeMaker::version::vpp module) (@INC
> contains: /bin/lib
> /usr/local/lib/perl5/site_perl/5.32/x86_64-cygwin-threads
> /usr/local/share/perl5/site_perl/5.32 
> /usr/lib/perl5/vendor_perl/5.32/x86_64-cygwin-threads
> /usr/share/perl5/vendor_perl/5.32 
> /usr/lib/perl5/5.32/x86_64-cygwin-threads /usr/share/perl5/5.32) at
> (eval 11) line 1.
> BEGIN failed--compilation aborted at (eval 11) line 1.
> Compilation failed in require at
> /usr/share/perl5/5.32/ExtUtils/MakeMaker.pm line 10.
> BEGIN failed--compilation aborted at
> /usr/share/perl5/5.32/ExtUtils/MakeMaker.pm line 10.
> Compilation failed in require at /usr/share/perl5/5.32/CPAN.pm line 48.
> BEGIN failed--compilation aborted at /usr/share/perl5/5.32/CPAN.pm line 48.
> Compilation failed in require at /usr/share/perl5/5.32/App/Cpan.pm line 290.
> BEGIN failed--compilation aborted at /usr/share/perl5/5.32/App/Cpan.pm
> line 290.
> Compilation failed in require at /bin/cpan line 10.
> BEGIN failed--compilation aborted at /bin/cpan line 10.

So your ExtUtils::MakeMaker installation seems incomplete, you need to
install the perl-ExtUtils-MakeMaker package at least.


Achim.
-- 
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Wavetables for the Waldorf Blofeld:
http://Synth.Stromeko.net/Downloads.html#BlofeldUserWavetables


More information about the Cygwin mailing list