vboxsharedfs - Too many levels of symbolic links

Takashi Yano takashi.yano@nifty.ne.jp
Mon Dec 6 03:31:35 GMT 2021

On Sun, 5 Dec 2021 16:49:13 +0200
Oskar Skog wrote:
> But if I create a symlink on that filesystem, it's not identified as a
> symlink. Although, I don't know if this has ever worked as it is the
> first time I've ever tested it, it probably hasn't ever worked (see
> below).
> user@DESKTOP-******* /cygdrive/z$ ln -s report.pdf test.pdf
> user@DESKTOP-******* /cygdrive/z$ ls -l report.pdf test.pdf
> -rw-r--r-- 1 user None 1454562 Nov 28 12:05 report.pdf
> -rw-r--r-- 1 user None      34 Dec  5 16:36 test.pdf
> user@DESKTOP-******* /cygdrive/z$ cat test.pdf
> !<symlink>▒▒report.pdfuser@DESKTOP-******* /cygdrive/z$
> I think it's because "special" attributes don't work on VirtualBox
> shared folders, I can't hide files in Explorer either.
> So I don't think the patch has caused any regression here.

I cannot reproduce that behaviour.

yano@DESKTOP-LSNFFD0 /cygdrive/z

yano@DESKTOP-LSNFFD0 /cygdrive/z
$ ln -s a b

yano@DESKTOP-LSNFFD0 /cygdrive/z
$ ls -l b
lrwxrwxrwx 1 yano None 1 Dec  6 12:17 b -> a

yano@DESKTOP-LSNFFD0 /cygdrive/z
$ cat b

yano@DESKTOP-LSNFFD0 /cygdrive/z
$ mount
C:/cygwin/bin on /usr/bin type ntfs (binary,auto)
C:/cygwin/lib on /usr/lib type ntfs (binary,auto)
C:/cygwin on / type ntfs (binary,auto)
C: on /cygdrive/c type ntfs (binary,posix=0,user,noumount,auto)
D: on /cygdrive/d type iso9660 (binary,posix=0,user,noumount,auto)
Z: on /cygdrive/z type vboxsharedfolderfs (binary,posix=0,user,noumount,auto)

Are you running VirtualBox in non-windows host by any chance?
cygwin symbolic link seems to work only in NTFS file system.

If shared folder is in linux file system, cygwin symbolic link
does not work.

Takashi Yano <takashi.yano@nifty.ne.jp>

More information about the Cygwin mailing list