I have a problem with some applications in Cygwin

René Berber rene.berber@gmail.com
Thu Oct 22 21:27:39 GMT 2020

On 10/22/2020 9:15 AM, Eirik Nordbrøden via Cygwin wrote:

> I have been using for many years and have not really had any major
> problems, but now I have run into a problem with some of the
> applications in Cygwin that I have been struggling with for some time
> without being able to solve it. Hopefully someone in this list can
> point me in the right direction to fix the problem.
> I have a new Windows 10 PC with a fresh Cygwin installation, but
> struggles with some of the applications that I have installed. When I
> try to use applications like ssh, ssh-keygen, git, snmpwalk, snmpnext

Just an idea, all of those are network tools, that means they depend on 
DNS resolving, which may be slow if not set correctly.

Have you tried using numeric IP addresses?

> etc. they all just hangs and I am not able to stop them through
> CTRL-C. I need to use Task Manager to kill the application (kill -9

That is very strange, Cygwin's programs respond to Ctrl-C fast.

Are you sure you are using the Cygwin program, for instance ssh, and not 
the Microsoft program (of the same name)?

> does not work either). But if I run the application from gdb (like
> 'gdb ssh-keygen' and the 'run') they seem to work. Most applications
> seems to work as expected, but not the ones I have listed (and maybe
> some more applications as well).
> I think that this might be due to something in my PC, but are not
> able to pinpoint it. At one point I thought that this was due to the
> virus control in the PC (Trend), but now I have uninstalled this and
> just uses Windows defender.

Good point and it needed to be tested, so that is out of the picture.

Repeating what I hinted to above, maybe running the program under gdb 
you are specifying the whole path to the program, which is not the same 
as letting the shell find it.  Try: `which ssh` to see which one is used.

Another test is to use ldd or cygcheck to take a look at the libraries 
loaded... if they include anti-virus or other strange libraries, then 
that is interfering.

Also using strace could (probably will) show where everything stops.


More information about the Cygwin mailing list