Trouble with starting XWin, "(EE) Can't read lock file /tmp/.XO-lock"

rtroy@ScienceTools.com rtroy@ScienceTools.com
Wed Nov 18 22:02:43 GMT 2020


Hey everyone,

SUPER long time Cygwin user, seldom need help, and my versions are all 
ancient now and I can't upgrade, I don't think. I'm on Windows 7 and am 
stuck there. Other version data follows.

Everything had been working fine for years, then I had a system crash and 
on restart, this is the only error I can find.

When run from the Cygwin shell command line, it goes like this:

------------------
$ XWin :0 -multiwindow -clipboard -wgl -ac -listen tcp
Welcome to the XWin X Server
Vendor: The Cygwin/X Project
Release: 1.19.2.0
OS: CYGWIN_NT-6.1 Okrasa 2.8.0(0.309/5/3) 2017-04-01 20:47 x86_64
OS: Windows 7 Service Pack 1 [Windows NT 6.1 build 7601] (Win64)
Package: version 1.19.2-1 built 2017-03-09

XWin was started with the following command line:

XWin :0 -multiwindow -clipboard -wgl -ac -listen tcp

(EE) Fatal server error:
(EE) Could not create lock file in /tmp/.tX0-lock
winDeinitMultiWindowWM - Noting shutdown in progress
$
------------------

I tried with window IDs 1 and 2 instead of zero but these didn't work 
either.

Later, while busy with other things, there was a power failure for the 
facility and when the power came back on, of course the system had 
rebooted so I tried again and got the same thing.

...Somehow early in my testing to get this going, without intentionally 
doing anything else, I noticed the error changed from "Could not create 
lock file in", to "Can't read lock file /tmp/.X0-lock".

Looking for the directory previously mentioned, it wasn't there so I 
decided to try and create that directory. When I do that, the error goes 
back to "Could not create lockfile in". ... I wonder if I created it with 
the right ownership and permissions, so I tried several things with no 
success.

...I'm rather desperate to fix this as this feature has become a key tool 
for this particular system. Ideas? Help?

Thanks,
RT


More information about the Cygwin mailing list