Autoconf files need v2.69

Brian Inglis Brian.Inglis@SystematicSw.ab.ca
Wed Nov 18 18:52:13 GMT 2020


On 2020-11-18 11:19, Biswapriyo Nath via Cygwin wrote:
> I am not familiar with newlib. Please feel free whatever you want to
> do with my previously provided diff. Also my previous question is
> unanswered.

Cygwin provides autoconf 2.69 but it's what builds the package that counts, also 
perhaps what is available in the cross-build toolchains supported by newlib for 
some platforms with limited support.

Some packages or platforms may have maintainers that are not comfortable with or 
have difficulty updating their autotools infrastructure, so that part of the 
process languishes: some packages are notorious for how old their autotools 
requirements are.

Some packages will not build if autoreconfiged, why old releases are still 
supported: autoconf/autoheader/autoreconf/autoscan/autoupdate 2.13-2.69, 
automake 1.4-1.16.

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in binary units and prefixes, physical quantities in SI.]


More information about the Cygwin mailing list