Autoconf files need v2.69

Biswapriyo Nath nathbappai@gmail.com
Wed Nov 18 09:36:51 GMT 2020


Currently the autoconf files in newlib-cygwin repo are in 2.64 version
but the latest autoconf package is version 2.69. So, autoreconf
command shows errors. Possible diff attached.
-------------- next part --------------
diff --git a/config/override.m4 b/config/override.m4
index 52bd1c3..1c3c298 100644
--- a/config/override.m4
+++ b/config/override.m4
@@ -29,7 +29,7 @@ m4_copy_force([_AC_PREREQ], [AC_PREREQ])
 
 dnl Ensure exactly this Autoconf version is used
 m4_ifndef([_GCC_AUTOCONF_VERSION],
-  [m4_define([_GCC_AUTOCONF_VERSION], [2.64])])
+  [m4_define([_GCC_AUTOCONF_VERSION], [2.69])])
 
 dnl Test for the exact version when AC_INIT is expanded.
 dnl This allows to update the tree in steps (for testing)
@@ -56,7 +56,7 @@ GNU M4 1.4.16 or newer and set the M4 environment variable]))])
 
 dnl Fix 2.64 cross compile detection for AVR and RTEMS
 dnl by not trying to compile fopen.
-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.64],
+m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.69],
   [m4_foreach([_GCC_LANG], [C, C++, Fortran, Fortran 77],
      [m4_define([_AC_LANG_IO_PROGRAM(]_GCC_LANG[)], m4_defn([AC_LANG_PROGRAM(]_GCC_LANG[)]))])])
 
diff --git a/configure.ac b/configure.ac
index cf856e5..f1d4af2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,7 +31,7 @@ m4_include([lt~obsolete.m4])
 m4_include([config/isl.m4])
 
 AC_INIT(move-if-change)
-AC_PREREQ(2.64)
+AC_PREREQ(2.69)
 AC_DISABLE_OPTION_CHECKING
 
 progname=$0


More information about the Cygwin mailing list