cmake suddenly stopped working

Mark Geisert mark@maxrnd.com
Tue Nov 17 22:48:00 GMT 2020


Norton Allen wrote:
> Windows 10
> 
> Cygwin installed all up to date
> 
> cmake 3.17.3-2, which does not appear to have changed since August
> 
> Symptoms: cmake fails silently with (or without) any arguments, including --help. 
> Exit code is 127

That exit code usually indicates a missing library at runtime.

> I tried to reinstall cmake, the file appears to be identical
> 
> cygcheck -s and cygcheck /usr/bin/cmake both look OK to to me, though I'd be happy 
> to upload if anyone is interested.
> 
> My AV is ESET. Tried disabling it to no effect.
> 
> This could have been caused by a recent cygwin update. The following were all 
> installed last Friday. Would anyone like to guess which are worth checking? I will 
> cross-check with the cygcheck output for cmake.
> 
> Is anyone else seeing this? Any suggestions?

I'm not seeing it.  'cmake --help' works for me.
Does 'ldd /usr/bin/cmake' give any hint?

..mark


More information about the Cygwin mailing list