Console doesn't work correctly under anything else than cmd or mintty

Eric Lilja
Wed May 13 08:50:50 GMT 2020

I had a similar experience when I tried to use the CLI that comes with
MongoDB. Switched to use TakeCommand instead when I needed to use the
MongoDB CLI. Too bad!

- Eric L

On Tue, May 12, 2020 at 11:05 PM Kacper Michajlow via Cygwin <> wrote:

> Hi,
> I was testing latest master (e637d53) and console is clunky in anything
> that isn't cmd.exe or mintty. I tested Microsoft Terminal and ConEmu.
> For example navigating with arrows doesn't work in vim. In zsh searching
> history with up arrow when there is beginning of the command doesn't work.
> And so on, sometimes Home button doesn't work to jump to beginning of the
> line or Backspace to clear input.
> It used to work better. I have tried CYGWIN=disable_pcon but didn't help
> really.
> Is it known problem? Is there a workaround? Should this be fixed in Cygwin
> or somewhere else?
> Thanks,
> Kacper
> --
> Problem reports:
> FAQ:        
> Documentation:
> Unsubscribe info:

More information about the Cygwin mailing list