Downgrading Cygwin components and dependencies

Maarten Hoes hoes.maarten@gmail.com
Fri May 8 16:44:26 GMT 2020


On Fri, May 8, 2020 at 6:17 PM Marco Atzeri via Cygwin <cygwin@cygwin.com>
wrote:

> Am 08.05.2020 um 14:10 schrieb Maarten Hoes via Cygwin:
> > Hi,
> >
> >
> > In another thread (that I did not want to hijack) it was mentioned that
> you
> > can downgrade (parts of) your cygwin installation by selecting
> > previous/older versions of things.
> >
> > In the cygwin installer, I can select (a few) older versions of the
> > components by clicking on the drop down menu next to the package names.
> > However, it appears that this only downgrades the package you explicitly
> > selected, and does not automatically downgrade components that depend on
> > it.
>
> Correct. It is supposed to be used on the seldom case that a specific
> new package is not working
>
> > For example, if I select a previous version of 'xorg-server', I would
> > expect that all packages that have a dependency on that to also be
> > downgraded (in this example, perhaps 'xorg-server-common' and
> > 'xorg-server-extra'). But this does not seem to be the case.
>
> To much expectation. It is not the case.
>
Hrm. I was kinda hoping for a full-fledged package manager. Oh, well.




>
> The list of packages built with the same source is mentioned here:
> https://cygwin.com/packages/summary/xorg-server-src.html
>
> Thanks for pointing that out.



> Setup is NOT looking at this information.
>
I understand now.


Why do you need to downgrade the X server ?
>
The current/latest version of Cygwin does not give me the 'full desktop
experience' (startmenu,toolbar, right click-on-desktop for context menu,
etc.) for KDE or GNOME. The only desktop that seems to work reliably for me
with 'current' cygwin seems to be Xfce. I asked about that in another
thread ('Cygwin/X: KDE Desktop'), but no-one seemed to know how to fix it.
Now, in an attempt to figure out for what version this worked for the last
time (and perhaps the first version it broke), I looked towards downgrading
X11 up till the point it still worked, so people more capable than me can
perhaps try to figure out what version/changes caused the
breakage.(Alternative approaches to troubleshoot this issue are welcomed of
course).


PS:
During google searching, I found the 'Cygwin Time Machine'. It archives
past Cygwin 'snapshots' (read: all packages that were 'current' at some
given date in the past). I fully realize this is by no means a 'supported'
configuration, but I dropped back to this date "2018/10/01", and at least
the "GNOME Flashback (Metacity)" works as expected now when it did not with
'current' Cygwin. Even LXDE seems to start correctly with this release at
least 'every other time' (like another poster mentioned in another thread).
Perhaps I need to go back further to find a release where both KDE and
GNOME worked.



[1]
http://www.crouchingtigerhiddenfruitbat.org/Cygwin/timemachine.html


- Maarten


More information about the Cygwin mailing list