mpi.mod of openmpi40 Version 3.1.5-1 cannot be used with gfortran5 9.3.0-2

Neder, Reinhard reinhard.neder@fau.de
Mon May 4 13:14:26 GMT 2020


Hi,
I can no longer compile my fortran program with gfortran5 Version 
9.3.0-2 with openmpi40 version 3.1.5-1
I receive the error message


$ mpif90 simple.f90
simple.f90:2:4:

     2 | USE mpi
       |    1
Fatal Error: Cannot read module file ‘mpi.mod’ opened at (1), because it 
was created by a different version of GNU Fortran
compilation terminated.

For the code:
PROGRAM simple
USE mpi
END PROGRAM simple

Used to work just fine for many years, I did not find the openmpi source 
code on cygwin itself.

Sincerely
Reinhard Neder

-- 
Prof. Dr. Reinhard Neder
Kristallographie und Strukturphysik
Universität Erlangen
Staudtststr. 3; 91058 Erlangen
tel. +49-9131-8525191
fax  +49-9131-8525182
--
DISCUS Workshop 2016 
http://www.lks.physik.uni-erlangen.de/DISCUS/index.html


More information about the Cygwin mailing list