Command expansion inside for loop

Mark Hansen
Wed Jul 8 11:47:22 GMT 2020

On 7/7/2020 3:06 PM, Mike Brown wrote:
> On Tue, Jul 07, 2020 at 04:45:28PM -0500, Mike Brown wrote:
>> On Tue, Jul 07, 2020 at 04:17:43PM -0500, Mike Brown wrote:
>> > Several years ago I was provided with info on how to get command expansion
>> > to work inside for loops.  I run under Zsh.  It was done for the install that
>> > I have under XP.  I've since installed cygwin under Win7-64 and want to get
>> > the expansion working again, but do not remember what was done to get it
>> > to work.
>> Brain fart.  Never an issue with XP, as the Zsh version is 2.4.6.  The Win7
>> version is 5.3.
>> I thought I had it working.  It might be because I think I reinstalled
>> cygwin as I redid the OS.  In any event, it is no longer working.
> Nevermind.  I found it.  It was when I went to Fedora 25 and a 5.x version
> of Zsh that the issue arose.  I dug thru some e-mail and it was via the
> Zsh mail list that I was provided with the answer.  It was Jun 14, 2017,
> that I updated the .zshrc file.  Brain got fuzzy over the three years.
> I added the changes to the cygwin version of my .zshrc file and it worked.
> MB

You got us reading three posts, so we're fully invested in your issue, and then
you don't share the answer? That's just cruel :)

More information about the Cygwin mailing list