bash 127 errors after upgrade and other install errors

Takashi Yano takashi.yano@nifty.ne.jp
Mon Jan 13 05:51:00 GMT 2020


On Mon, 13 Jan 2020 04:21:58 +0000
Henry Goss wrote:
> Sure, here are the steps to reproduce either. Run on windows 10.
> 
> RE: working installation:
> 1) open setup program. tick python3.6, python3.6 dev tools. Install.
> The new installer doesn't recognize the old version of python. I don't recall the old installation method. But If it was not done with setup, it was done with apt-cyg
> 
> When I install, setup attempts the following:
> Uninstall python3-setuptools 34.3.2-1 (automatically added)
> Install crypto-policies 20190218-1 (automatically added)
> Install libcrypt2 4.4.4-1 (automatically added)
> Install libgdbm6 1.18.1-1 (automatically added)
> Install libgdbm_compat4 1.18.1-1 (automatically added)
> Install libnsl2 1.2.0-1 (automatically added)
> Install libssl1.1 1.1.1d-1 (automatically added)
> Install libtirpc-common 1.1.4-1 (automatically added)
> Install libtirpc3 1.1.4-1 (automatically added)
> Install python-pip-wheel 19.2.3-1 (automatically added)
> Install python-setuptools-wheel 41.2.0-1 (automatically added)
> Install python36 3.6.9-1
> Install python36-devel 3.6.9-1
> Install python36-setuptools 41.2.0-1 (automatically added)
>  
> This breaks python.
> 
> At some point, you an uninstall, reinstall, etc and get python working. However it will still lead to the problem with python and selenium below
> 
> 
> MYSQL
> Uninstall mysql 10.1.30-1 (automatically added)
> Uninstall openssl-devel 1.0.2o-1 (automatically added)
> Install crypto-policies 20190218-1 (automatically added)
> Install libgdbm6 1.18.1-1 (automatically added)
> Install libgdbm_compat4 1.18.1-1 (automatically added)
> Install libmariadb-devel 3.0.9-1 (automatically added)
> Install libmariadb3 3.0.9-1 (automatically added)
> Install libssl-devel 1.1.1d-1 (automatically added)
> Install libssl1.1 1.1.1d-1 (automatically added)
> Install mariadb-common 3.0.9-1 (automatically added)
> Install mysql 10.3.14-1
> Install mysql-devel 10.3.14-1
> 
> This breaks mysql.
> 
> 2) steps to reproduce python selenium.
> - Run set, select emacs, python 3.5,6 or 7 and associated dev tools.
> - install.
> - from prompt:
> 	- python -m ensurepip --default-pip
> 	-pip3.6 install selenium
> 	"
> 		pip3.6 freeze
> 	 	selenium==3.141.0
> 	 	urllib3==1.25.7
> 	"
> 	Sample python test code.
> 	from selenium import webdriver
> 
> 	EXE_PATH = r'/cygdrive/c/webdriver/chromedriver.exe';
> 	#driver = webdriver.Chrome(executable_path=EXE_PATH)
> 
> 	#driver = webdriver.Chrome(executable_path=EXE_PATH, service_args=["--verbose", "--log-path=run.log"])
> 	driver = webdriver.Chrome(service_args=["--verbose", "--log-path=run.log"])
> 	driver.get('https://google.com')
> - at this point, the program will hang. It looks like its waiting to connect to chromedriver. 
>  running task manager on windows 10, will yield two python3.x processes. This may be expected behavior, I presume its opened with a fork and the child process socket is not closed. Closing the child causes the main to run, cutting the main breaks execution. This appears to be a problem with any python 3.x installation I have done.
> 
> Cancelling via ctrl-c yields the following:
> Traceback (most recent call last):
>   File "test.py", line 20, in <module>
>     driver = webdriver.Chrome()
>   File "/usr/lib/python3.6/site-packages/selenium/webdriver/chrome/webdriver.py", line 73, in __init__
>     self.service.start()
>   File "/usr/lib/python3.6/site-packages/selenium/webdriver/common/service.py", line 76, in start
>     stdin=PIPE)
>   File "/usr/lib/python3.6/subprocess.py", line 729, in __init__
>     restore_signals, start_new_session)
>   File "/usr/lib/python3.6/subprocess.py", line 1318, in _execute_child
>     part = os.read(errpipe_read, 50000)
> KeyboardInterrupt

Thanks for the report.

I could not reproduce the problem 1).

As for the problem 2), it seems to be the same problem with
https://www.cygwin.com/ml/cygwin/2020-01/msg00093.html.

I already submitted a patch for that issue:
https://www.cygwin.com/ml/cygwin-patches/2020-q1/msg00010.html.

I confirmed the problem 2) is fixed with this patch.

Please wait for the new cygwin release.

-- 
Takashi Yano <takashi.yano@nifty.ne.jp>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list