Cygwin 3.1.X Fatal Errors - add_item ("\??\C:", "/", ...) failed, errno 22

Marco Atzeri
Sun Jan 12 17:51:00 GMT 2020

Am 12.01.2020 um 14:47 schrieb Ken Turner:
> This is related to I
> have now tried the same update on two other systems.
> Cygwin 3.0.7-1 32-bit works fine on three different systems: one Windows 7
> 64-bit, two Windows 10 64-bit. However, Cygwin 3.1.1-1 and 3.2.1-1 fail to
> install cleanly on these systems and leave me with a Cygwin installation
> that gives fatal errors.
> In response to Marco Atzeri's comments:
> | testing on my W10 64bit a clean 32bit installation from scratch
> | I seen no issues
> The problem may be due to an update from a previous version of Cygwin rather
> than a clean install. I haven't yet tried completely uninstalling and
> reinstalling Cygwin on these systems, but will do so if necessary.

you can just make a installation in a different directory.


06.01.2020  08:35    <DIR>          cygwin-x86
12.03.2019  07:18    <DIR>          cygwin32
24.11.2019  18:40    <DIR>          cygwin32T
23.12.2019  05:49    <DIR>          cygwin64
12.03.2019  07:27    <DIR>          cygwin64T

> | for what I know exit code=-1073741819 is in
> | HEX FFFF FFFF C000 0005
> |
> | and Exception code c0000005 is the code for an access violation
> That's correct. It's something deep within Cygwin that's failing. After
> trying to install Cygwin 3.1.1-1 or 3.2.1-1, I rebooted to make sure that
> the new cygwin1 DLL was being used. All Cygwin binaries (dash, ls, rebase,
> etc.) then fail with:
> *** fatal error - add_item ("\??\C:", "/", ...) failed, errno 22
> This may be due to a forking issue rather than a rebase issue. On tracing
> "ls" there is a strange reference to '\??\C'. Could that be related to a
> cygdrive prefix problem or a mount problem?

the format is fine

$ grep '??' ls.strace
   257  109044 [main] ls 1951 symlink_info::check: 0x0 = NtCreateFile 
   185  112242 [main] ls 1951 symlink_info::check: 0x0 = NtCreateFile 
   179  113275 [main] ls 1951 symlink_info::check: 0x0 = NtCreateFile 
   262  123254 [main] ls 1951 symlink_info::check: 0x0 = NtCreateFile 

> I wonder why Cygwin 3.0.7-1 would work fine but not any later version.
> Evidently there is a significant difference in later versions.

there are several changes between 3.0.x and 3.1.y
some are not perfect and still some polishing is in progress

> I see the same errors when trying to update three different systems (one
> Windows 7, two Windows 10), so it isn't specific to one system. These also
> have different mounts for different disks (respectively C: is an HDD, C: is
> an SSD, C: is an SSD and D: is an HDD).
> What is common to these systems is that they are 64-bit Windows being used
> with 32-bit Cygwin, that Cygwin is installed in the root of the C drive, and
> that I'm trying to update from Cygwin 3.0.7-1 rather than doing a clean
> install.

try a parallel minimal installation just as double check


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list