fork: Resource temporarily unavailable errors after upgrading cygwin packages

David Finnie
Wed Jan 1 22:32:00 GMT 2020

Hi Ken,

Thanks for having a look at my issue.

On 1/01/2020 06:20, Ken Brown wrote:
> On 12/30/2019 6:10 PM, David Finnie wrote:
>> I recently upgraded my cygwin64 installation to get latest packages.
>> After the install, if I run a fairly lengthy GNU make with multiple concurrent
>> jobs (-j option) specified, some of the sub-makes fail with "Resource
>> temporarily unavailable" errors. In all cases, this has been when make is
>> starting a shell (i.e. $(shell ...) ) to help with setting up some of the
>> variables required in the make processing. The failure, however, occurs in
>> different places in the make files used (the make spawns several sub-makes).
> Does this happen with every parallel make, or is it one specific program that
> you're building?  If the latter, can you give a detailed recipe so that others
> can try to reproduce the problem?

It's happening consistently across a bunch of libraries and executables 
that I build (with a series of invocations of make). While each of those 
builds has their own Makefile, each of them includes a common set of 
makefiles that does the vast majority of the work, so I guess you could 
say that it really is just isolated (as far as I can tell), to one build 
environment. The build is not of open source software - it is for 
software created by the company I work for, so unfortunately I can't 
share all of the source code etc., but I can certainly give details of 
what we're doing.

The make builds a cross-platform set of products, and so invokes both 
Windows native compilers, and also cross compilers for the other 
platforms (Linux, and HPE NonStop). So there are many tools being 
invoked simultaneously.

Keep in mind, though, that this has been working perfectly for me for 
over a decade. I will say that I did run into the need to run rebase 
after upgrading cygwin many years ago, but that fixed the issue for me 
immediately. Not so this time, and there has been nothing else changed 
in my environment. I actually ran the build successfully just minutes 
before upgrading the cygwin packages, and then it failed immediately 
after that.

I have not tried building for any other product. I might try that.

> Have you tried reverting to cygwin-3.0.7-1? 

No, I haven't - I'll try that now. Thanks.

> The only thing that jumps out at me from your cygcheck output is that your PATH
> is very long.  I don't know if that's relevant, but you might try cutting it
> down before running make.

I did try changing PATH to a much smaller value 
(/bin:/usr/bin:/usr/local/bin) but I still got exactly the same 
behaviour :-( A good thing to try, though.

I'll see how I go after downgrading cygwin.

Thanks again.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list