Cygwin SSH - seteuid no such device or addresss

jinsu mathew via cygwin
Sun Feb 23 10:33:00 GMT 2020

I've setup Cygwin and want to ssh with domain user account on windows server 2012 R2. It works fine if I start the sshd service with "Local system account" but if I start the service with a "cygserver" local account or "domain\cygserver" then the service starts fine but when I try to ssh I see the message sshd: PID 1944: fatal: seteuid 1801: No such device or address.
ssh in verbose mode on the client shows the following:
debug1: Authentication succeeded (publickey).Connection to closed by remote host.Connection to closed.debug1: Exit status -1.
Some articles like suggest to enable the following GPO with cygserver account in it. I tried them still the same error.
Following GPO's are enabled.Act as part of the operating systemCreate a token objectLog on as a serviceReplace a process level token
I've verified .ssh and authorized_keys permission and the user home directory exists and also passwd file has the /bin/bash shell for the user.
Any suggestion on how to resolve this issue?

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list