CPU hogging by dysfunctional bash or zsh when started via mintty Cygwin terminal link

Ken Brown kbrown@cornell.edu
Fri Feb 14 02:40:00 GMT 2020

On 2/13/2020 9:08 PM, Jan-Marek Glogowski wrote:
> Hi *,
> I've already been on IRC (jmux) and had a longer debug session, trying
> various stuff suggested by MetaNova. This is a Cygwin64 install.
> Quoting from IRC: "After a longer time (probably months), I tried to
> open a cygwin terminal, which now fails. It results in an empty window
> with a blinking cursor and a bash process with 100% CPU load. The box is
> a Windows 10 VM and also runs an cygwin openssh server, which I normally
> use for development. SSH still works fine. I also installed gdb and
> tried to attach to the CPU hogging bash, but I never see a gdb prompt
> just some gdb startup output."
> The condensed version, of what I already did and didn't change the result:
> * updated cygwin install
> * gdb -p <bash hog pid> -> hangs
>    - killing bash will "start" gdb with the message, that the process
> already exited
> * starting zsh via the mintty link results in zsh hogging the CPU.
> * cygwin.bat works; same for starting bash.exe from cmd
> * reinstall mintty incl. "rebase-trigger fullrebase" didn't help
> * strace mintty from a cygwin.bat shell results in a SIGSEGV
>    - log currently at http://paste.debian.net/1130528/
>    - expires: 2020-02-17 01:57:45
> * gdb mintty results in ~ the same result, then gdb -p
>    - it creates some threads, a bash hog window is created with all the
> other "helpers" and gdb returns with "[Inferior 1 (<pid I guess)>)
> exited with normally]" to the gdb prompt
>    - quitting gdb and returning to the bash prompt won't happen, until I
> kill the bash window, so basically the same, then doing "gdb -p"
> This all looks like a mintty problem.
> What else can I do to debug / fix this problem?
> Regards,
> Jan-Marek
> P.S. Windows installed some updates today, but since I don't know when I
> opened a terminal the last time, I can't tell if that is related.

Your strace output shows that sysfer.dll is loaded.  This is apparently a 
component of Symantec Endpoint Protection.  Could the latter be interfering with 
Cygwin?  See



Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list