Building libusb1.0 from source fails (Attn maintainer)

Marco Atzeri marco.atzeri@gmail.com
Sun Feb 2 05:38:00 GMT 2020


Am 02.02.2020 um 02:23 schrieb Doug Henderson:
> Windows 10 Home
> 10.0.17763 Build 17763
> 
> $ uname -a
> CYGWIN_NT-10.0 mars 3.1.2(0.340/5/3) 2019-12-21 15:25 x86_64 Cygwin
> 
> fully patched as of today (no test versions or snapshots installed)
> 
> 
> Building libusb1.0 from source using
> 
> $ cygport libusb1.0.cygport download
> $ cygport libusb1.0.cygport prep
> $ cygport libusb1.0.cygport compile
> 
> fails with:
> 
> /usr/src/libusb1.0-1.0.21-1.src/libusb1.0-1.0.21-1.x86_64/src/libusb-1.0.21/libusb/io.c:
> In function ‘usbi_io_init’:
> /usr/src/libusb1.0-1.0.21-1.src/libusb1.0-1.0.21-1.x86_64/src/libusb-1.0.21/libusb/io.c:1167:2:
> error: implicit declaration of function ‘close’; did you mean
> ‘_lclose’? [-Werror=implicit-function-declaration]
>    close(ctx->timerfd);
>    ^~~~~
>    _lclose
> cc1: some warnings being treated as errors
> 
> I also built with the latest upstream release, but that generates a
> great many warnings, which I have not attempted to resolve.
> 
> Any guidance to resolve this is appreciated.
> 
> Doug
> 

attached patch solve the build issue.

Regards
Marco

-------------- next part --------------
--- origsrc/libusb-1.0.21/libusb/io.c	2016-10-25 18:07:38.000000000 +0200
+++ src/libusb-1.0.21/libusb/io.c	2020-02-02 06:33:05.141074300 +0100
@@ -27,6 +27,7 @@
 #include <stdlib.h>
 #include <string.h>
 #include <time.h>
+#include <unistd.h>
 #ifdef HAVE_SIGNAL_H
 #include <signal.h>
 #endif
-------------- next part --------------

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple


More information about the Cygwin mailing list