katomic and atomix will not run

Eliot Moss moss@cs.umass.edu
Sat Apr 18 16:20:49 GMT 2020

On 4/18/2020 11:40 AM, Phoenix Soul wrote:
> No, I haven't. What is it and how do I run one?
> On Fri, Apr 17, 2020 at 3:23 PM Eliot Moss <moss@cs.umass.edu <mailto:moss@cs.umass.edu>> wrote:
>     On 4/17/2020 5:16 PM, Phoenix Soul via Cygwin wrote:
>      > I decided that I was going to get katomic and atomix for cygwin, and
>      > selected the most recent version listed.
>      > atomix refuses to run and says:
>      > Unable to init server: Could not connect to <>: Connection refused
>      >
>      > (atomix:1495): Gtk-WARNING **: cannot open display:
>      > katomic says:
>      > QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to
>      > '/tmp/runtime-warri_000'
>      > qt.qpa.screen: QXcbConnection: Could not connect to display
>      > Could not connect to any X display.
>      > I have already tried using source as well. I have already pinged
>      > (localhost) to ensure that it does exist. What must be done to fix it.
>      > Windows version is 8.1, and this is a no admin installation.
>     ... and you have an X server already running?  Maybe some details
>     about that end of things will help folks help you ...

Well that explains your error messages :-) ...

An X server deals with the screen, and X windows applications, such as the
ones you're trying to run, connect to it to get their stuff displayed.

The guide to X on Cygwin may be found at https://x.cygwin.com/docs/ug/.
I also find the XLaunch program to be helpful.  Maybe someone else has a
short cookbook list of things to do or can direct you to particular
sections of the guide ...

Regards - EM

More information about the Cygwin mailing list