Using ARM GNU GCC with Cygwin

Sat Apr 4 18:15:25 GMT 2020

On 4/4/20 5:23 AM, Eliot Moss wrote:
> On 4/4/2020 5:00 AM, Ben wrote:
> > I've been playing with ARM GNU GCC and some examples from nordic semiconductor for some of their
> > demo boards (The Thingy)
> Sounds as if that is a Windows program, not a Cygwin or Linux program.
> > The make file that comes with the project includes source files using the (abspath ../main.c) (as
> > one example) which GCC really seems to hate.
> > The output from GCC is the full path (/home/bkamen/workspace-nordic/.....) right down to the file
> > and gcc tells me it can't find the file.
> If your gcc is a Windows gcc then it wants a Windows path.
> > if I change the mail file to use a relative path, gcc can find that... but ultimately I'm trying to
> > understand the issue than just patch around it.
> This goes along with my theory.
> > I'm using the arm-gcc from the website.
> >
> > Is there something else I'm missing? What files can I offer (like the makefile) that can help
> > determine the issue?
> You can fix the Makefile to pass Windows paths.  The cygpath tool and make's
> $(shell ...) command might be useful.
> But I also wonder if maybe the mingw environment is more suited to this work,
> or finding a Windows version of make.

Yea, that's what I figured.

I thought I would try it and see how it worked out -- and it was so close... that I figured it'd be worth asking if anyone had worked with doing something similar.



More information about the Cygwin mailing list