sshd: fatal: seteuid XXX : No such device or address

Corinna Vinschen
Thu Mar 14 12:10:00 GMT 2019

On Mar 14 12:39, wrote:
> Hello the list, 
> Thanks for all the work and effort put into this.
> Since two days i cannot login anymore (password less) with ssh into my
> server
> Server is : 
> Microsoft Windows Server 2012 R2 Essentials / 6.3.9600 N/A version 9600
> Cygwin was not up to date, but I have since updated it
> CYGWIN_NT-6.3 [MACHINE NAME] 3.0.3(0.338/5/3) 2019-03-09 19:12 x86_64 Cygwin
> I can login via password, it work and lets me in.
> But if i tried with my keys, I get in the event viewer :
> sshd: PID 3777: fatal: seteuid 1049076: No such device or address
> I tried googling around, reinstalled multiple times sshd, the user and the
> service with no luck so far.
> I was working for several years now.
> For now I have no clue, so i'm asking what did I do wrong ?

You should try two things:

- Make sure to login with the Administrator account case-sensitive.
  If your account is called "Administrator", then use an uppercase
  'A' when logging in.

  This case-sensitivity issue is a temporary workaround for a
  potential security problem in OpenSSH.  This will be rectified
  with OpenSSH 8.0 which allows to login case-insentive again.

- If that doesn't help, switch the user running the sshd service from
  "cyg_server" to SYSTEM (the services GUI calls it "LocalSystem")

  Cygwin switched the logon method and this method doesn't run
  under the "cyg_server" account sometimes.  However, switching
  back to "LocalSystem" instead of having to create a special
  "cyg_server" service account is one of the advantages of the
  new logon method.  For details, see


Corinna Vinschen
Cygwin Maintainer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <>

More information about the Cygwin mailing list