cmake cmake gui and soci 4 with postgresql

Gavin M2301
Tue Mar 12 23:19:00 GMT 2019


I kind of hoped that when I selected cmake gui from Cygwin mirror that it
would know which dependencies I needed. I tried to launch it by typing
cmake-gui into mintty and it did not load.

I installed PostgreSQL for win 10 and then installed the command line tools
for Cygwin and that went well. I tried it out and it is working.

The creator of SOCI 4 said, no one tried to test soci with Cygwin.I don't
see why it matters in this case whether I am using Cygwin or not. I use
minGW to build DLLs with PostgreSQL headers and library files for my

cmake kept saying about it didn't recognize directory. It would pull the
path from mintty. I tried to pass it windows style paths but whatever
mintty had displayed in the console it would pick that. For e.g.
/cygdrive/c/cygwin64/home/username/soci-master is considered invalid.
#1: Is there an easy way to get cmake-gui installed in Cygwin? Do I need
both X and qt installed or can it figure out the dependencies?
#2: Does it matter that I am using mintty when running cmake with all of
its options?

I guess the easiest way to put it is I am just trying to run cmake to an
end which is to build binaries and lib files and do not care too much
(within reason) about its inner workings.

thx. for any assistance- roboloki

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list