sshd problem on WS2008R2 64bit

Corinna Vinschen
Wed Mar 6 14:17:00 GMT 2019

On Mar  6 13:48, Corinna Vinschen wrote:
> On Mar  6 13:11, Corinna Vinschen wrote:
> > On Mar  5 17:02, Stephen Carrier wrote:
> > > Since upgrading a WS2008 R2 system to 3.0.1, attempts to ssh to the server
> > > fail unless some user logs into Windows first.  In this case, that is by
> > > RDP, and it doesn't need to be the same user as the one logging in by ssh.
> > > After logging out of the windows-native session, ssh continues to work.
> > > 
> > > Windows event logs report a failed attempt for "NULL SID" and
> > > 
> > > ----
> > > Failure Reason: An error occured during Logon.
> > > Status:         0xc00000bb
> > 
> > This is weird.  Status 0xc00000bb is STATUS_NOT_SUPPORTED.  That
> > doesn't make sense, at least not on 2008 R2 with 64 bit Cygwin.
> > 
> > Are you trying to login via sshd with a local account or a domain
> > account?
> > 
> > I tried to reproduce your issue with Cygwin 3.0.2 on a Windows 10
> > machine.  I rebooted the machine and did not login locally or via
> > RDP.  Sshd login worked in both cases (local/domain account).
> > 
> > Can you test this again, in particular with installing Cygwin 3.0.2?
> > 
> > In the meantime, I need some time to set up a Windows 2008 R2
> > machine for testing.
> Never mind, I can reproduce the problem on Windows 7, but only
> for local machine accounts.  Domain accounts work fine.

This is *so* weird.

When I run the service under the cyg_server account, then the S4U logon
for the local SAM user works as expected, even right after reboot.
The weird thing here is that my cyg_server account is a domain account.

What this has to do with the MsV1_0S4ULogon for a local SAM account
beats me.  The only explanation I have for that is that the service
running under the domain cyg_server account constitutes some kind of
"local login", so MsV1_0S4ULogon subsequently starts working.

This cyg_server account does not necessarily require the "create token"
permission anymore, of course.

Big sigh here.

With S4U I had hoped to catch two birds with one stone:

- Getting rid of two old methods, cyglsa and "create token".

- Dropping the requirement for the cyg_server account.

But the old Systems like Windows 7 don't want to play nice.

- On Vista and Windows 7 WOW64, MsV1_0S4ULogon isn't implemented
  at all, which required to keep the create_token method

- On Vista and Windows 7 MsV1_0S4ULogon does not work without
  some user logged in locally, even if it's just the cyg_server
  service account.

Question is, what is a good solution?  Reverting cyglsa as 
well to allow the old methods to work as before?  This is
the opposite of what I had hoped to accomplish :(


Corinna Vinschen
Cygwin Maintainer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <>

More information about the Cygwin mailing list