sshd problem on WS2008R2 64bit

Corinna Vinschen
Wed Mar 6 12:48:00 GMT 2019

On Mar  6 13:11, Corinna Vinschen wrote:
> On Mar  5 17:02, Stephen Carrier wrote:
> > Since upgrading a WS2008 R2 system to 3.0.1, attempts to ssh to the server
> > fail unless some user logs into Windows first.  In this case, that is by
> > RDP, and it doesn't need to be the same user as the one logging in by ssh.
> > After logging out of the windows-native session, ssh continues to work.
> > 
> > Windows event logs report a failed attempt for "NULL SID" and
> > 
> > ----
> > Failure Reason: An error occured during Logon.
> > Status:         0xc00000bb
> This is weird.  Status 0xc00000bb is STATUS_NOT_SUPPORTED.  That
> doesn't make sense, at least not on 2008 R2 with 64 bit Cygwin.
> Are you trying to login via sshd with a local account or a domain
> account?
> I tried to reproduce your issue with Cygwin 3.0.2 on a Windows 10
> machine.  I rebooted the machine and did not login locally or via
> RDP.  Sshd login worked in both cases (local/domain account).
> Can you test this again, in particular with installing Cygwin 3.0.2?
> In the meantime, I need some time to set up a Windows 2008 R2
> machine for testing.

Never mind, I can reproduce the problem on Windows 7, but only
for local machine accounts.  Domain accounts work fine.

Oh well,

Corinna Vinschen
Cygwin Maintainer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <>

More information about the Cygwin mailing list