Postfix+Cygwin: "mail system startup failed"

Greywolf greywolf@starwolf.com
Wed Jun 19 23:08:00 GMT 2019


Greetings!

First the important stuff:
[uname -a]:
CYGWIN_NT-10.0 milliways 3.0.7(0.338/5/3) 2019-04-30 18:08 x86_64 Cygwin

[windows]:
Windows 10 Pro for Workstations
Build 16299.rs3_release_svc.180808-1748

[this is a work computer so getting updates for it may not be possible]

Now the problem:

I'm trying to get postfix up and running, and all I get is "fatal: mail system
startup failed", with no further explanation; to wit, from 'postfix -v start':

[since the IPs are all RFC-1918, I don't really care about their visibility...]

postfix: name_mask: ipv4
postfix: name_mask: subnet
postfix: inet_addr_local: configured 8 IPv4 addresses
postfix: been_here: 192.168.238.0/24: 0
postfix: been_here: 192.168.40.0/22: 0
postfix: been_here: 169.254.0.0/16: 0
postfix: been_here: 169.254.0.0/16: 1
postfix: been_here: 169.254.0.0/16: 1
postfix: been_here: 192.168.44.0/22: 0
postfix: been_here: 169.254.0.0/16: 1
postfix: been_here: 127.0.0.0/8: 0
postfix: mynetworks: 192.168.238.0/24 192.168.40.0/22 169.254.0.0/16
192.168.44.0/22 127.0.0.0/8
postfix/postfix-script: starting the Postfix mail system
postfix/postfix-script: fatal: mail system startup failed
[end output]

Between starting and fatal, I expect that I would get a more detailed dump
of what's gone wrong.  Anyone have any insight?

				--*greywolf;

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list