Dragging from explorer to cygwin terminal is not putting the path into the terminal

Thomas Wolff towo@towo.net
Sun Jun 9 13:05:00 GMT 2019

Am 08.06.2019 um 15:12 schrieb Brian Inglis:
> On 2019-06-08 01:10, Thomas Wolff wrote:
>> Am 08.06.2019 um 02:52 schrieb Academy OfFetishes:
>>> On Fri, Jun 7, 2019 at 5:41 PM Doug Henderson wrote:
>>>> On Fri, 7 Jun 2019 at 11:33, Academy OfFetishes wrote:
>>>>> On Fri, Jun 7, 2019 at 12:41 AM Thomas Wolff wrote:
>>>>> I have the same problem with 3.0.0.
>>>>> Sorry for slowly dripping out information (I promise that's not my
>>>>> intent), but I will say, as soon as I created this user account on
>>>>> windows, I had copy and paste issues that were outside of cygwin.  I
>>>>> recall copying text from firefox and not being able to paste it into
>>>>> windows explorer and vice versa (these are contrived examples.  I can't
>>>>> remember what the exact problems were, but they were similar to this).
>>>>> It seemed very random, though.  Like some copy/paste worked, and some
>>>>> did not.  After running sfc /scannow and restarting twice, the problem
>>>>> seems to have gone away completely.
>>>>> I'm not sure if that's to this problem (except that it could point out
>>>>> a borked windows install).
>>>> I encountered strange clipboard problems as a result of fiddling with
>>>> the Clipboard Settings in Win10.
>>>> When I turned on "Sync across devices", after a "Copy to clipboard"
>>>> operation, sometimes the "Paste from clipboard" operation pasted
>>>> nothing or the previous clipboard content. A few moments later,
>>>> another "Paste" would paste the content of the most recent "Copy". It
>>>> seems as though the content of the clipboard was not updated after a
>>>> Copy operation until a Sync to cloud was performed, with the timing
>>>> being dependant on WiFi, internet and cloud speeds and latency.
>>>> I did not observe any difference in "Drag and Drop" behaviour with
>>>> this setting, but I almost exclusively use keyboard Copy and Paste
>>>> instead of mouse Drop and Drag.
>>> That's interesting.  Well my sync settings already seems to be off, but
>>> when I was having issues, it was working just like you described.
>>> I'm not sure if I'm supposed to create a new Mintty issue or wait for
>>> Thomas to reply.
>> 1. Please note that this list has a no-top-posting policy. (Respond below the
>> text you're referring to.)
>> 2. Latest comments are suggesting this may not be a mintty issue.
>> 3. I can only reply if there is a clear question or issue presented. Even though
>> I noticed the issue once myself, there is still no "reproducible test case".
> The OP has a reproducible test case: file drag to cmd always works, file drag to
> mintty never works: fails on both 3.0.0 and 3.0.7; the rest of us have no
> problems: diagnosis opportunity!
For me it works, mostly. It only failed under erratic circumstances, not 

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list