UPX compressed setup-x86_64.exe crashes on Win10

Michael Wild themiwi@gmail.com
Mon Jan 21 08:03:00 GMT 2019


Dear all

I recently got a new laptop at work with Win10 (1709). I went ahead,
downloaded setup-x86_64.exe and wanted to install Cygwin. However, it
crashes with a segmentation fault. Trying to get to the bottom of
things I got the sources on my old laptop and compiled the thing,
copied it to the new laptop, and surprisingly it worked. I then tried
the stripped version. Again, it worked. However, when I tried to run
the UPX compressed executable, I got the segfault again.

Anybody else experiencing this? I tried trawling through the mailing
list, but nothing specific turned up. Maybe this is an interaction
with the BLODA imposed on me by our company IT policy. But then I'd
expect others to have seen this issue too.

Cheers

Michael

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list