Cygwin installer does not select the packages specified by the -P option

Achim Gratz
Wed Aug 7 18:42:00 GMT 2019

KAVALAGIOS Panagiotis (EEAS-EXT) writes:
> I have tried the -A option, the -B option as single user to no
> avail. There is no antivirus running. Well, there is in general in our
> PCs, but no installed on my test machine. I have also tried another
> mirror to re-download the packages in a local repository, but it
> didn't work either. Can you provide your local repo data to check?

That repo is not public, no.  But if you've mirrored the repo with
setup.exe (like your directory name seems to suggest), then I don't see
why the repo structure should be wrong.

> Just to ensure that my local repo is not the problem.

Again, check the Windows DACL on the local repo directory down to the
actual files.  If you have "interesting" inheritable DACL, that can lead
to lots of fun behaviour.

>>Again, it should just work the way you were trying, but something's
> Probably, but I would need more information to prove it. I am
> suspecting a Windows Group Policy, but I would have to be sure and
> prove it in order to request the exception from our Windows Team.

I've been at the receiving end of group policies gone wild, but your
symptoms don't seem to click with that.  You might try to rename
setup.exe to something entirely else, lest somebody targeted certain
program names.

> I forgot to mention that we are using Windows 7 and I don't know if
> the setup behaves different on that operating system.

I still have the odd Win7 box here and there around, I don't think that
this makes any difference.

+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

SD adaptation for Waldorf microQ V2.22R2:

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list