Openldap 2.4.48-1 vs my company's pki

Achim Gratz
Wed Aug 7 18:35:00 GMT 2019

David Goldberg writes:
> I found the problem. I guess there's a number of locations where .ldaprc
> can be found. I have an old backup of a Linux home directory under my
> cygwin home and that contained a .ldaprc with a TLS_CACERTDIR setting that
> makes no sense on my windows box.

I looked through the sources and I didnÄt find a place that would pick
up a config file in a random directory.  The user config is indeed
picked up in the $CWD of the running process, but all other configs are
in fixed places.

> I removed it and also the ldap.conf I just created and ldapsearch
> worked as expected. I can't understand why 2.4.42 ignored that file
> while 2.4.48 tried to use it but it seems local to my oddball
> situation and not a broader issue.

OK, so I consider the case closed.

+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Samples for the Waldorf Blofeld:

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list