Openldap 2.4.48-1 vs my company's pki

David Goldberg
Mon Aug 5 12:22:00 GMT 2019

Sorry, was away from work over the weekend. I just tested with openssl
s_client and it works just fine.  Version is 1.1.1.  there is no self
signed certificate. It's signed with the company pki rather than commercial
and I've properly installed that chain. The problem send to be with the new
build, at least the weird ldd output leads me to that conclusion. I'll try
to find some time to build from source and see if it works.


On Sat, Aug 3, 2019, 02:43 Achim Gratz <> wrote:

> David Goldberg writes:
> > Thanks but unfortunately even after don't that I still get the complaint
> > that they're is a self signed certificate in the chain. We do indeed run
> > our own CA but it seems like that should not really be a problem.
> Wait, are you saying you do run a private CA, but the LDAP server cert
> is not certified through it?  Running
> openssl s_client -connect ldap:9010
> shows the certificate chain as seen by openssl and would tell you if
> you've registered the right cert to trust.  You can compare this to what
> ldapsearch outputs when run with a sufficiently high debuglevel to see
> if there's some obvious mismatch that would indicate a configuration
> error somewhere.  As a last resort you can run
> env LDAP_REQCERT=never ldapsearch ...
> to skip the certificate check and see if that at least works.  But you
> said it worked before, so that might not be the problem here...
> So let me guess that you need to point your ldap.conf to
> /etc/pki/... instead of /etc/ssl/... (which was the earlier default).
> Also, please read the update announcement about the state of the server
> components (if you use them).
> Regards,
> Achim.
> --
> +<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+
> Wavetables for the Terratec KOMPLEXER:
> --
> Problem reports:
> FAQ:         
> Documentation:
> Unsubscribe info:

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list