Regression (last snapshot)

Ken Brown kbrown@cornell.edu
Thu Aug 1 12:20:00 GMT 2019


On 8/1/2019 6:03 AM, Houder wrote:
> On Wed, 31 Jul 2019 15:53:27, Ken Brown  wrote:
> 
>> I've made some progress. It turns out that the problem only occurs in terminals
>> launched from the xwin-xdg-menu tray icon.  I can even launch a mintty window
>> from that icon (System Tools -> Cygwin Terminal) and I'll see the problem.  On
>> the other hand, I can launch an xterm without using that icon (e.g., 'DISPLAY=:0
>> xterm -l&' from a mintty window) and I won't see the problem.
> 
> No one confirmed your problem, as described in your initial posting. Did nobody
> care, or did the problem only exist at your place?
> 
> I became curious ...
> 
> I do not use X! (on Cygwin).
> 
> Therefore I created a separate (basic) Cygwin installation, where I added xinit,
> xorg-server and xterm only!
> 
> Next I started xterm as follows:
> 
>      64-++ startx /usr/bin/xterm -geometry 140x50+530+180 -- -rootless
> 
> The problem occured when using cywin1.dll 0712 (as expected), but not when using
> cygwin1.dll 3.0.7 or cygwin1.dll 0722.
> 
> I concluded, that your problem does not occur w/ a "basic" X configuration.

As I said, the problem only occurs in terminals started from the xwin-xdg-menu. 
That isn't what you did.  Here are the reproduction instructions again:

1. Start the X server using the XWin Server shortcut in the Start Menu (look 
under Cygwin-X).

2. Locate the xwin-xdg-menu tray icon.  It looks like a black C with a green X 
inside.  If you hover over it, you'll see "X applications menu on :0".  Click on 
that icon, hover over System Tools, and select one of the terminals offered.

3. Try your 'ls' command or some variation of it in that terminal.

On my system I see the broken pipe error from grep half of the time or more if 
use your original test 'ls -lL <(grep bash .bashrc)'.  If I use the simpler 'ls 
<(grep bash .bashrc)', I see the error about 98% of the time.  And if I use the 
even simpler 'echo <(grep bash .bashrc)', I see the error 100% of the time.

Ken
 ТÒÐÐ¥&ö&ÆVÒ&W÷'G3¢‡GG¢òö7–wv–âæ6öÒ÷&ö&ÆV×2æ‡FÖÀФd¢‡GG¢òö7–wv–âæ6öÒöfðФFö7VÖVçFF–ö㢇GG¢òö7–wv–âæ6öÒöFö72æ‡FÖÀÐ¥Vç7V'67&–&R–æfó¢‡GG¢òö7–wv–âæ6öÒöÖÂò7Vç7V'67&–&R×6–×ÆPРÐ


More information about the Cygwin mailing list