out of handles

Andrey Repin anrdaemon@yandex.ru
Wed Nov 21 19:50:00 GMT 2018

Greetings, jeff kish!

> I am trying to get cygwin X-win to work with putty.
> Right now the situation is:

> I have a Windows 7 operating system on my laptop. On this laptop
> I have an old 1.11.2 version of cygwin - when I fire up the X-Win server,
> my putty can connect and run IBMIM just fine (an IBM installation app on a
> target CENTOS system that uses eclipse for its interface).

> I have a newer version that gets an error about not being able to get
> handles:
> [main] org.eclipse.equinox.log.internal.ExtendedLogReaderServiceFactory
> safeLogged
>   Application error
>   org.eclipse.swt.SWTError: No more handles [gtk_init_check() failed]

> Finally I downloaded the very latest version and had the same error...

> I tried loading the libs I could find from this post, but it still fails
> with the handles error.

> Does anyone have any steps to fix/troubleshoot?

By default, modern X servers are not configured to accept TCP connections.
You have to explicitly tell the one you are using to do so.

With best regards,
Andrey Repin
Wednesday, November 21, 2018 22:36:21

Sorry for my terrible english...

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list