Bug: No json support anymore in Ruby 2.3.6

Ronald Fischer ynnor@mm.st
Tue Nov 20 08:41:00 GMT 2018


Since I updated Ruby to 2.3.6, the standard library json is missing:

 ruby -e 'require "json"'
/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- json (LoadError)
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from -e:1:in `<main>'


The other standard libs which I tried, are present, for example:

 ruby -e 'require "yaml"; require "set"'

(no error here).

Ronald
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 35268 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20181120/0bba54d2/attachment.obj>
-------------- next part --------------

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple


More information about the Cygwin mailing list