normal to blue-screen windows when doing 'ls -CF' of /proc/sys/GLOBAL?? (bug? cygcheck attached)

Brian Inglis
Thu May 17 19:41:00 GMT 2018

On 2018-05-17 02:54, L A Walsh wrote:
> Andrey Repin wrote:
>> After BSOD, there should be at least aminibump.
>> You can use to examine it.
> ----
>     Tried it...showed nothing.  Checked sysprops and the small memory dump (256KB)
> is enabled -- should have dumped in C:\windows\Minidump, but nothing was
> there.
> I did try to see the module when the blue screen was up, but
> it rebooted too quickly.
>> Do you perhaps have some misbehaving drivers in your system?
>> Try clearing up your device manager.
>> SET DEVMGR_SHOW_NONPRESENT_DEVICES=1 && mmc.exe devmgmt.msc
> ---
>     Didn't see anything that stood out, but took the opportunity to remove all
> the ones that didn't refer to existing HW.
> FWIW --- It almost has to be some misconfigured SW -- not any specific
> HW, since this windows image did the same thing on my last system.
> I had to get a new system and moved over the hard disk - updated needed
> drives and I was up (about 4-5 months ago).
> Very wierd.  It triggers so fast, and whatever is causing it, likely
> happens on a probe by 'ls' before ls even displays any output.
> I 'can' go into the same directory and do a "echo *" (or better,
> printf "%s\n" *  --- and that doesn't trigger it.
> I think I also triggered it once with 'tree'.  Very annoying.
> Oh well, I suspected it wouldn't be simple, which is why I just try to
> "not do that"...but it had been a while, and thought maybe...
> *grumble*
> thanks for the ideas all...

Run "cygcheck ls" to see if any Windows installs added to your path pick up
api-ms-win-core-... intercept dlls e.g. Firefox, Tortoise, etc.
Tried running same command under strace?
BLODA possibly messing up net access to AD?

Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list