compiling GRASS GIS in Cygwin and Windows 10

Marco Atzeri
Wed May 16 14:28:00 GMT 2018

On 5/16/2018 9:57 AM, Massi Alvioli wrote:
> Hi all,
> I need a bit of help with GRASS GIS compiled with cygwin and Windows
> 10. Right after a Cygwin update,
> a few weeks ago, my GRASS 7.2 gui stopped working with a cryptical
> Cygwin-related error message reported below.
> I tried rolling back a few wxPython-related Cygwin packages to
> previous versions, but I had no luck. I also run rebase
> a few times, as suggested to heal similar problems in some web
> location. Same result going to grass74 (to which the
> errors above refer). The source package is here:
> and the list of options used to compile GRASS and a cygcheck dump are
> attached here!
> ----- --- -- -
> GRASS 7.4.0 (italia):~ >       1 [main] python2.7 8396
> child_info_fork::abort: unable to map
> C:\cygwin64\bin\cygSDL2-2-0-0.dll, Win32 error 1114

It seems python failed to load cygSDL2-2-0-0.dll

I assume that the output of
   cygcheck cygSDL2-2-0-0.dll
is fine, but probably one of the dependency was incorrectly updated.
Look if there is any /usr/bin/*.new file.

For further dependency check you can use on cygSDL2-2-0-0.dll
or run the python compiler under strace.

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list