unable to map cygSDL error

massimiliano nocharge@gmail.com
Fri Jun 22 18:27:00 GMT 2018

Ken Brown-6 wrote
> On 6/14/2018 11:22 AM, Massi Alvioli wrote:
>> As you mention in your post, I ran into the same problem:
>> https://cygwin.com/ml/cygwin/2018-05/msg00207.html
>> so I would like to know if you can help me solve the problem.
> Until someone figures out the underlying cause of the "unable to map" 
> error for cygSDL*.dll, my only suggestion is to try to work around the 
> problem as I did for gimp: avoid using SDL.  In your case, I think SDL 
> is brought in via the package libwx_gtk3u3.0_0.  If you look at the 
> source for that package, you'll see that it uses the configure option 
> --with-sdl.  So you could try to rebuild it without that option.
> Hi Ken,
> I tried to compile the libwx_gtk3u3.0_0 package: I installed the package 
> source using cygwin's setup, then cd /usr/src/wxWidgets3.0-3.0.3-1.src,
> edited wxWidgets3.0.cygport to remove --with-dsl, and issued the commands
> cygport wxWidgets3.0.cygport prep/compile/test/install. After installing 
> loads of new cygwin packages required to build wxwidgets, I compiled
> GRASS GIS again but still I have no luck - same "unable to map
> cygSDL2xxx.dll
> error message at startup.
> Is there any obvious flaw in my procedure? any other idea?  
> thanks in advance.
> Massi

Sent from: http://cygwin.1069669.n5.nabble.com/Cygwin-list-f3.html

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list