Fwd: [fixed] Stubborn ghostscript 9.19 not upgrading to 9.23

Heavenly Avenger avenger@avenger.ws
Sat Jul 21 09:35:00 GMT 2018

Sorry, problem solved...

$ cygcheck -c libgs9
Cygwin Package Information
Package              Version        Status
libgs9               9.23-1         OK

$ cygcheck -l libgs9

$ ls -l /usr/bin/cyggs-9.dll
-rwxr-xr-x 1 avenger None 11816979 Jun 29  2016 /usr/bin/cyggs-9.dll

Yeah, cygcheck, yeah...  (notice 2016 above?) :P

Seems cygcheck -c does not really pokes checksum of every file in the 
package? I wonder why this didn't report as corrupt.

After reinstalling libgs9:
$ ls -l /usr/bin/cyggs-9.dll
-rwxr-xr-x 1 avenger Administrators 12393491 Mar 21 17:58 

$ gs --version

Works now. I guess I should just search for 2016 DLLs within /usr/bin 
and assume them all as broken, and reinstall the packages. :)

-------- Forwarded Message --------
Subject: 	Stubborn ghostscript 9.19 not upgrading to 9.23
Date: 	Fri, 20 Jul 2018 22:58:45 -0300
From: 	Heavenly Avenger <avenger@avenger.ws>
To: 	cygwin@cygwin.com


I got into this problem that ghostscript refuses to upgrade.

If I try to run a rtf2ps.sh I used to do frequently, I'm getting this:

Looking for the error I see somebody mentioning it should be under
/usr/share/gs/*. I have only /usr/share/ghostscript/*, and it looks like
the same. Therein, I have 9.19 and 9.23 directories, which suggests
there's some leftovers from 9.19. Yet, if I try to find the missing file
(gs_init.ps), I get it within the 9.23 tree. Then it /should/ be good.

Then, moved to /usr/bin and:

$ ./gs --version
$ ls /usr/share/ghostscript/
9.19  9.23  fonts

I closed all cygwin terminals, checked up whether no cygwin process was
running, and performed a reinstall of the ghostscript package. It reads
9.23 in setup_x86_64.exe, so I left a little confuse as to why it is not
getting updated... maybe the package is nuts? Double checked, gs.exe
process is not running nor stuck.

Any ideas about what's going on here? :) I would prefer to be able to
fully upgrade the package, but if the only way is to keep the old one or
do some hacky symlinks, I guess I would need to live with that. :(

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list