After installing nc (netcat), nc.exe is not found

Mark Hansen meh@winfirst.com
Thu Jul 12 01:30:00 GMT 2018


On 7/11/2018 12:41 PM, Andrey Repin wrote:
> Greetings, Mark Hansen!
> 
>> I've just updated to the latest Cygwin 64-bit installation on my Windows 7 PC. Included
>> in this update was the package for nc (nc: A simple but powerful network tool) version 1.107-4
> 
>> After downloading and installing, which all seemed to go fine, the man page for nc is there,
>> but nc.exe is not.
> 
>> I included the following (netcat-related) packages:
>> - nc, 1.107-4
>> - nc6, 1.0-1
>> - nc6-debuginfo, 1.0-1
> 
>> Is there something special I need to do to get nc.exe installed?
> 
> Check your antivirus quarantine area.
> 
> 

Well, that's certainly one problem. Both nc.exe and nc6.exe were trapped by the corporate virus checker.
The software allowed me to "restore" it, but when I try to run it I get "Permission Denied".

However, after a few minutes, it's gone again. I'm guessing the virus checker software is doing it.
Unfortunately, it looks like it won't let me create an exception for these executables, so I don't
have any way to stop it from deleting them :(

... and I know better than to ask my corporate IT folks to make an exception for me :(




--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list