After installing nc (netcat), nc.exe is not found

Mark Hansen
Wed Jul 11 20:00:00 GMT 2018

On 7/11/2018 12:34 PM, Mark Hansen wrote:
> On 7/11/2018 10:34 AM, Heavenly Avenger wrote:
>> I have these versions, and nc is here happy and playful.
>> It is possible you attempted an upgrade while cygwin programs were
>> running? Cygwin services also count. This is due a limitation on windows
>> which locks files when they are in use, so cygwin updates can't replace
>> the files and end up failing.
>> You may ensure everything is closed and services stopped, re-run
>> setup-x86_64.exe, selecting the 'nc' package and switching it to
>> "Reinstall". Then let the setup do its things.
>> If the setup is hanging, or have hung up and you had to force-close it
>> the last install attempt you did, this is a strong sign that not just
>> nc, but several other packages that have been attempted to upgrade may
>> be compromised. To ensure that is not the case, a good
>> cygcheck -c
>> should help.
>> The package nc-1.10-4.tar.bz2 has 'usr/bin/nc.exe', which is the file
>> you claim missing.
>> Hope this helps! :)
> Thanks for your help. I have notes that show what all I need to shut down when doing the
> install. I caught all them (Cygwin SSHD, Cygwin cygserver, the X Server, and anything running
> cygwin shells, etc.) - I think that's everything.
> When I run cygcheck -c, it shows Incomplete on the two packages (nc and nc6) so they definitely
> had problems, and appear to be the only ones which did.
> I see that the .bz2 file is in my downloads area (I download to local without install, and then
> install from local).
> I tried running bunzip2 on that file and then extracting it using tar. The bunzip2 completed
> quickly but the tar command took a long time (I'm not sure what it was doing during this time).
> I'll try shutting everything down and doing a reinstall on the netcat stuff.
> Thanks,

There is an error happening during the installation. I get a pop-up with the following:

   Can't open x86_64/release/libfm-qt/libfm-qt5-common/libfm-qt5-common-0.11.1-1.tar.xz for reading: Unknown filename

This appears to be what is keeping nc and nc6 from installing properly.

There are lots of .xz files in the release, so perhaps the problem is the file name is too long?

Is there some way I can work around this?


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list