Fwd, Solved: Entry point not found issues with cygwin DLLs

Heavenly Avenger avenger@avenger.ws
Mon Jul 2 19:35:00 GMT 2018

Hi! Uh... I seem to have been able to solve the issue using 
'cygcheck.exe -c' (found a suggestion on using it here: 
https://stackoverflow.com/questions/42591821, so credits for them, 
although it was just a mention he ran 'cygcheck.exe').

It parsed all packages that were missing files in the system, and I 
reinstalled each package, and voila, all works.

Here's the list of the corrupted packages I had:

aria2                                 1.32.0-1 Incomplete
binutils 2.29-1                Incomplete
cygwin 2.10.0-1              Incomplete
cygwin-debuginfo 2.10.0-1              Incomplete
cygwin32 2.10.0-1              Incomplete
ghostscript 9.23-1                Incomplete
libgcrypt-devel 1.8.2-1               Incomplete
libgpg-error-devel 1.28-1                Incomplete
libmcrypt-doc 2.5.8-1               Incomplete
ruby-doc 2.3.6-1               Incomplete
ruby-json 2.0.4-1               Incomplete
ruby-rdoc 5.1.0-1               Incomplete
rubygems-doc 2.6.13-1              Incomplete
subversion-tools 1.10.0-2              Incomplete
urw-base35-fonts 20170801-5            Incomplete
vim-common 8.0.1567-1            Incomplete
whois 5.2.10-1              Incomplete

(yes, whois didn't work either, annoying but could live with that! the 
-doc ones weren't quite a problem, but I wonder how they went missing 

The most worrysome ones were: binutils, cygwin, cygwin32, 
libgcrypt-devel, libgpg-error-devel

And I am especially suspicious of the main one being the 
libgcrypt-devel, although the cygwin and cygwin32 ones being very likely 

Besides, now version info from cygwin1.dll reads 2010.0.0, 2.10.0. I 
have no idea how that 2.8.0 survived there throught updates. :)

Sorry for the first message being a known and easy issue. I had 
exhausted my searches when I delivered it .. just by luck I found that 
cygcheck tip and it worked, as murphy's laws dictate (after I poked the 
big guys I found myself I didn't really need to).

Anyway, I hope the experience and solution helps others around!

-------- Forwarded Message --------
Subject: 	Entry point not found issues with cygwin DLLs
Date: 	Mon, 2 Jul 2018 16:08:06 -0300
From: 	Heavenly Avenger <avenger@avenger.ws>
To: 	cygwin@cygwin.com


First post in the list, I hope I am not mistaken in the place to post
the question, but let's give it a try.

I'm having hard times with cygwin here, random libraries stop working
once I update or install new ones.

Today I run 'rebaseall' and it detected a lot of completely missing DLLs
from packages. So I wrote a script to build up the list of packages that
contained the DLLs to use setup-x86_64 to reinstall them.

After reinstalling, 'rebaseall' ran without apparent issues. But still
ssh and perl are unusable.

If I run the ssh client, it simply returns to the command prompt. Perl
likewise. Passing any commandline parameters does not change it.

If I run ssh with 'strace' ('strace ssh'), it pops up a windows dialog

'the procedure entry point __memcpy_chk could not be located in the
dynamic link library c:\cygwin\bin\cygcrypto-1.0.0.dll'

I found this file is located in the 'openssl100-1.0.2o-1' package. The
file is present and has about 2.3MB in size. I've deleted the package's
tar from within my local cygwin packages cache and reinstalled. Still
the same.

With perl I get the same, but the complained file is called

Maybe I should be looking for that __memcpy_chk from another DLL; it may
be missing and strace/cygwin informs a misleading DLL name?

I'm using Windows 10 1709 / 16299.248.
cygwin's dll is: cygwin1.dll file version: 2008.0.0.0, version: 2.8.0.

Thanks in advance to whoever has suggestions on how to tackle with this
issue, it's been plaguing me for months now.

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list